Author Topic: Weatherlink has stopped working...  (Read 8801 times)

0 Members and 1 Guest are viewing this topic.

Offline WokingWounded

  • Member
  • *
  • Posts: 2
Weatherlink has stopped working...
« on: May 05, 2013, 11:19:29 AM »
Hi
I’m running Weatherlink 6.0.3 on Windows 7 Pro (64) with a USB connection to my VP2. It worked fine. I’ve just returned from a few days away to find WL hung and a Windows dialogue saying “Weatherlink has stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available”. Of course there has been no such notification from Windows. I’ve tried several reboots, also uninstall and reinstall WL but I get the same message every time I try to start WL. Has anyone come across this before? Any idea how I can rectify the problem? There have been no recent Windows updates and the only change made on my setup recently was to update the driver on my Logitech mouse!

Offline Bunty

  • Forecaster
  • *****
  • Posts: 2197
  • Stillwater, home of Oklahoma State University
    • Welcome to Stillwater Weather
Re: Weatherlink has stopped working...
« Reply #1 on: May 05, 2013, 12:22:06 PM »
Weatherlink is pretty bad about doing that.  At least the way yours quits is different from mine.  Mine just quits without giving any message.  I have no suggestions to fix it. It just seems an undesirable characteristic of the program.  Thank goodness, another program, Weather Display, is less likely to quit.
« Last Edit: May 05, 2013, 12:24:56 PM by Bunty »

Also the 2nd home page using modified AltDashboard 6.95 at http://stillwaterweather.com/wx/2ndhome.php

Offline Bushman

  • Forecaster
  • *****
  • Posts: 7447
    • Eagle Bay Weather
Re: Weatherlink has stopped working...
« Reply #2 on: May 05, 2013, 12:33:27 PM »
In over 4 years (I think?) I have not had WL stop once - at least on XP.  I've tested in on W7/64 for weeks on end and it is fine.  So I dunno....  but you could try Startwatch to restart it when it hangs - it is now free!
Need low cost IP monitoring?  http://wirelesstag.net/wta.aspx?link=NisJxz6FhUa4V67/cwCRWA or PM me for 50% off Wirelesstags!!

Offline WokingWounded

  • Member
  • *
  • Posts: 2
Re: Weatherlink has stopped working...
« Reply #3 on: May 05, 2013, 02:03:25 PM »
Thanks for your comments. It's a mystery. I've run WL on XP for several years and upgraded to W7 last June. It's run OK since then although it occasionally froze requiring the programme to be closed and restarted. However, I've never had this problem where the program opens but doesn't repond and is then closed down by W7. It seems to run OK if I open it in XP compatibility mode - although, again, I'll have to see if it stays running. Watch this space. I've emailed Davis support to see if they have an angle.

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6403
    • Lee's Summit, MO
Re: Weatherlink has stopped working...
« Reply #4 on: May 06, 2013, 10:46:52 AM »
If the problem persists....
One quick thing to try.  Find the file 2013-05.wlk, back it up somewhere, and delete it.  Then try to restart WeatherLink.

If the failure might have occurred in April, also do that to 2013-04.wlk

============

Does the Windows 7 Event Viewer give any clues?  Or the WeatherLink log file?

Is WeatherLink the only weather software that you are using?

Offline jruys

  • Yo
  • Senior Contributor
  • ****
  • Posts: 221
    • Highlands Ranch Weather
Re: Weatherlink has stopped working...
« Reply #5 on: May 08, 2013, 12:06:44 AM »
Make sure the permissions on the WeatherLink folder didn't get changed some how.  You could try right-clicking on the application and running it as administrator to see if that might fix the problem as well.

Offline LFWX

  • Forecaster
  • *****
  • Posts: 1086
  • Liberty Township, Butler County, Ohio
    • Liberty Fairfield Weather Center
Re: Weatherlink has stopped working...
« Reply #6 on: June 08, 2013, 03:05:17 AM »
Wow, after running WeatherLink 5.7.1 for more than 5 years, I suddenly get this error.  ](*,)

I have VWS run WeatherLink each night at 11:55 pm to download from the data logger and then use WeatherLink to review and plot past data, I use it for no other functions - and until about an hour ago it always worked great.

I've tried reinstalling from the Davis site, even completely deleted my WeatherLink folder (after making a backup), deleted the 2013-06.wlk file (even tried deleting the 2013-05.wlk file), but as soon as I click "Make a plot" or "Browse the station data" I get the "WeatherLink has stopped working..." error.

Other than reinstalling from the original CD later today, should I try something else.

Should I try reinstalling again and create a "new station" before the data logger becomes full - with the hopes of being able to merge the old data with the new data?

PS - I just had WeatherLink download from the data logger, it loaded all 513 pages, but still gives the same error.
Station: Davis Vantage Pro2 Fan Aspirated
Software: Virtual Weather Station V14.00p64
OS: Windows Vista Home Premium
www.LFWeatherCenter.com
CWOP: DW1039
CoCoRaHS: OH-BT-1
Weather Underground: KOHHAMIL7
Weather For You: DW1039
Midwestern Weather Network

Offline ocala

  • Forecaster
  • *****
  • Posts: 3876
Re: Weatherlink has stopped working...
« Reply #7 on: June 08, 2013, 08:54:59 AM »
Wow, after running WeatherLink 5.7.1 for more than 5 years, I suddenly get this error.  ](*,)

I have VWS run WeatherLink each night at 11:55 pm to download from the data logger and then use WeatherLink to review and plot past data, I use it for no other functions - and until about an hour ago it always worked great.

I've tried reinstalling from the Davis site, even completely deleted my WeatherLink folder (after making a backup), deleted the 2013-06.wlk file (even tried deleting the 2013-05.wlk file), but as soon as I click "Make a plot" or "Browse the station data" I get the "WeatherLink has stopped working..." error.

Other than reinstalling from the original CD later today, should I try something else.

Should I try reinstalling again and create a "new station" before the data logger becomes full - with the hopes of being able to merge the old data with the new data?

PS - I just had WeatherLink download from the data logger, it loaded all 513 pages, but still gives the same error.
Try resetting the data logger. That same scenario happened to me and resetting the data logger fixed the issue.
1-Enter set up mode by pressing Done and Down arrow keys.
2-Remove power.
3-Remove logger
4-Wait one minute.
5-Reninstall logger.
6-Add power.
7-Press and hold Done key.

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6403
    • Lee's Summit, MO
Re: Weatherlink has stopped working...
« Reply #8 on: June 08, 2013, 10:13:42 AM »
Also:

1.. Make sure that the time is the same between the computer and the console.

2.  Look to see if you have .wlk files with "higher file names" than 2013-06.  [Like 2020-01.wlk or whatever].  Delete any of those.

Offline LFWX

  • Forecaster
  • *****
  • Posts: 1086
  • Liberty Township, Butler County, Ohio
    • Liberty Fairfield Weather Center
Re: Weatherlink has stopped working...
« Reply #9 on: June 08, 2013, 11:28:40 AM »
Wow, after running WeatherLink 5.7.1 for more than 5 years, I suddenly get this error.  ](*,)

I have VWS run WeatherLink each night at 11:55 pm to download from the data logger and then use WeatherLink to review and plot past data, I use it for no other functions - and until about an hour ago it always worked great.

I've tried reinstalling from the Davis site, even completely deleted my WeatherLink folder (after making a backup), deleted the 2013-06.wlk file (even tried deleting the 2013-05.wlk file), but as soon as I click "Make a plot" or "Browse the station data" I get the "WeatherLink has stopped working..." error.

Other than reinstalling from the original CD later today, should I try something else.

Should I try reinstalling again and create a "new station" before the data logger becomes full - with the hopes of being able to merge the old data with the new data?

PS - I just had WeatherLink download from the data logger, it loaded all 513 pages, but still gives the same error.
Try resetting the data logger. That same scenario happened to me and resetting the data logger fixed the issue.
1-Enter set up mode by pressing Done and Down arrow keys.
2-Remove power.
3-Remove logger
4-Wait one minute.
5-Reninstall logger.
6-Add power.
7-Press and hold Done key.

Since VWS is having no trouble communicating with the datalogger, I'd rather not delete the data stored on it just yet - but I may end up having to try that soon. Of course I can still use the data stored at WeatherUnderground and plug it in later using the WLKReaderWriter utility.

EDIT - I just now had WeatherLink download from the data logger and it only loaded 20% of the pages which would be correct. So, it doesn't seem to be a datalogger problem. I'll see if the WLKReaderWrite utlilty offers any solutions - I've never used it, but know of it's existance.
« Last Edit: June 08, 2013, 11:43:51 AM by LFWX »
Station: Davis Vantage Pro2 Fan Aspirated
Software: Virtual Weather Station V14.00p64
OS: Windows Vista Home Premium
www.LFWeatherCenter.com
CWOP: DW1039
CoCoRaHS: OH-BT-1
Weather Underground: KOHHAMIL7
Weather For You: DW1039
Midwestern Weather Network

Offline LFWX

  • Forecaster
  • *****
  • Posts: 1086
  • Liberty Township, Butler County, Ohio
    • Liberty Fairfield Weather Center
Re: Weatherlink has stopped working...
« Reply #10 on: June 08, 2013, 11:33:20 AM »
Also:

1.. Make sure that the time is the same between the computer and the console.

2.  Look to see if you have .wlk files with "higher file names" than 2013-06.  [Like 2020-01.wlk or whatever].  Delete any of those.

The time on the console is only 30 seconds behind the computer right now, I'll reset it anyway.

No stange .wlk files, however the "date modified" is the the same as the time when I tried to view the data this morning.
Station: Davis Vantage Pro2 Fan Aspirated
Software: Virtual Weather Station V14.00p64
OS: Windows Vista Home Premium
www.LFWeatherCenter.com
CWOP: DW1039
CoCoRaHS: OH-BT-1
Weather Underground: KOHHAMIL7
Weather For You: DW1039
Midwestern Weather Network

Offline LFWX

  • Forecaster
  • *****
  • Posts: 1086
  • Liberty Township, Butler County, Ohio
    • Liberty Fairfield Weather Center
Re: Weatherlink has stopped working...
« Reply #11 on: June 08, 2013, 12:26:10 PM »
I found the solution!!  :grin: :grin: :grin:

Per http://www.wxforum.net/index.php?topic=12710.0

I deleted the DataLists.dat & DataSets.dat files and everything is fine now, no data lost!

Thanks for the other possible soultions. Maybe this will help someone in the future.
Station: Davis Vantage Pro2 Fan Aspirated
Software: Virtual Weather Station V14.00p64
OS: Windows Vista Home Premium
www.LFWeatherCenter.com
CWOP: DW1039
CoCoRaHS: OH-BT-1
Weather Underground: KOHHAMIL7
Weather For You: DW1039
Midwestern Weather Network

Offline wascopete

  • Member
  • *
  • Posts: 1
Re: Weatherlink has stopped working...
« Reply #12 on: January 08, 2014, 02:02:33 PM »
It helped me last night. Thanks for the info.

Offline dj1111s

  • Weather obsessed
  • Forecaster
  • *****
  • Posts: 384
  • The "d" cloud.
Re: Weatherlink has stopped working...
« Reply #13 on: January 08, 2014, 10:18:56 PM »
Weatherlink.com appears to be down.  9:18 CST 1/8/14

Sorry false alarm. I was playing with my router and decided to try a new filter feature that was added with the last firmware update.  I clicked on the one that promised to block adult content as well as other malicious sites.  After testing it and finding it did not block any adult content I left it on to see if it would have any other interesting affects.  LOL, it blocked Weatherlink.
« Last Edit: January 08, 2014, 10:32:37 PM by dj1111s »
Vantage Pro2 Plus W/FARS, wireless anemometer, bucket heater with temperature sensor. Envoy, VP2 and Vue consoles. Meteobridge. Soil and leaf station. Attic temp and humidity.
Trained Storm Spotter
Member CoCoRaHS
You will never find me on Facebook or Twitter or any other social media!!!

Offline dalecoy

  • Forecaster
  • *****
  • Posts: 6403
    • Lee's Summit, MO
Re: Weatherlink has stopped working...
« Reply #14 on: January 08, 2014, 10:34:25 PM »
...weatherlink.com outage would have nothing to do with the subject of this topic, of course.

But thanks for the interesting report.

 

anything