Author Topic: New WeatherElement features...  (Read 11032 times)

0 Members and 1 Guest are viewing this topic.

Offline SLOweather

  • Administrator
  • Forecaster
  • *****
  • Posts: 3228
    • http://www.sloweather.com
New WeatherElement features...
« on: August 02, 2012, 02:04:37 PM »
A few months ago, we added data buffering to the Data Hub, 3,000 records. Now, depending on the update period, it will store a day (30 second updates) or more of data upon loss of Internet connection, and send them automatically to the server when the connection is restored. Because of this, we're getting 97% or better data from Tassajera peak, on a wireless link with >30% packet loss.

Just a bit ago, I pushed some new features to the live site, including station forecast from the NWS XML point forecast database, site pictures in the About page, and a dev version of conditions on an ElementSticker.



Any/all extra Davis wireless sensors are displayed on the site's home page. We're working on assigning them names and graphing them.

http://www.weatherelement.com/teddybearoaks

Also, we can set up uploads to PWSweather and WU from the server for any station that wants it.

Station networks have been working for a while, with the ability to put stations in many networks.

http://www.weatherelement.com/Network/SLO-LosOsos-Baywood

http://www.weatherelement.com/Network/SLOCounty

Also, some thing not live for users yet, but that we can finally do at the server level.

From the beginning, we set up the ability to set some commands back from the server to the Data Hub and console. Up til now, I haven't been able to use them. However, a problem with another station 35 miles a way (the console clock was 50 minutes slow) led me to find a way to do it.

So, now, from the server, we can set the time and date in the console, control the console backlight, and send some other WeatherElement specific commands, like whether or not to send extra sensor data. Yesterday I turned on and off the Vantage Vue console backlight in Rockton IL from California. :)

We are currently having a bit of trouble with the graphs, though. You have to refresh the page to see them, and the time axis is off. It's plotting them as if the time is EDT, even for stations that are CDT, MDT or PDT.