Author Topic: Alternative Drought Monitor Page  (Read 5328 times)

0 Members and 1 Guest are viewing this topic.

Offline Johnmac

  • Contributor
  • ***
  • Posts: 119
Re: Alternative Drought Monitor Page
« Reply #50 on: October 18, 2017, 07:51:28 AM »
The script in use at jonhsnhweather has the same problem I did - he's got the bad version that contains a problem with a reference to /pngs/ in $mapsURL = 'data/png/current/current';. Should be /png/ - no 's' - as shown. Check yours for the same thing?

I have checked for the added "s" on my script. it is the correct "png".
John
Westminster, MA USA

Offline jgillett

  • Forecaster
  • *****
  • Posts: 1150
  • unnamed weather station, Boltek, Win7 Pro, ToA
    • TiggrWeather Phoenix
Re: Alternative Drought Monitor Page
« Reply #51 on: October 18, 2017, 11:47:52 AM »
The script in use at jonhsnhweather has the same problem I did - he's got the bad version that contains a problem with a reference to /pngs/ in $mapsURL = 'data/png/current/current';. Should be /png/ - no 's' - as shown. Check yours for the same thing?

I have checked for the added "s" on my script. it is the correct "png".
OK - just a thought. The site I was mainly talking about was jonhsnhweather.
John
W7JKG
BUY FROM AMAZON  HERE... Thank You! :-)

Offline Johnmac

  • Contributor
  • ***
  • Posts: 119
Re: Alternative Drought Monitor Page
« Reply #52 on: May 22, 2018, 02:00:36 PM »
I have downloaded the wxdrought_maps.php the correct way and changed the necessary items in the settings and also uploaded the necessary animation files. I still get a blank map when the page loads and nothing happens when I mouseover the different states. The animation link works fine and I did update the link to my site.

Anything else I should look at?

Thanks,

John
For some reason the script is crashing somewhere near or in the state map display table, and nothing loads past that.  This means the mouseover 'show_tab' state name entries aren't loading either, so the script obviously doesn't work.

Running your home page through the validator.w3.org site produces errors right off the bat.  Perhaps clearing those up might help when it comes to troubleshooting the drought maps script?

Similarly, a blizzard of errors arise when running the drought maps script on your site through the w3 validator.  This is in contrast with what happens when the page on my site is validated by the https://validator.w3c.org site.

Start with your main site and work on the errors from the top down.  It can be brutal, frustrating work at first, but the end result is a cleaner page and a much greater understanding of scripting.  Remember, Google is your friend when it comes to understanding the errors' cause(s).
I have downloaded the wxdrought_maps.php the correct way and changed the necessary items in the settings and also uploaded the necessary animation files. I still get a blank map when the page loads and nothing happens when I mouseover the different states. The animation link works fine and I did update the link to my site.

Anything else I should look at?

Thanks,

John
For some reason the script is crashing somewhere near or in the state map display table, and nothing loads past that.  This means the mouseover 'show_tab' state name entries aren't loading either, so the script obviously doesn't work.

Running your home page through the validator.w3.org site produces errors right off the bat.  Perhaps clearing those up might help when it comes to troubleshooting the drought maps script?

Similarly, a blizzard of errors arise when running the drought maps script on your site through the w3 validator.  This is in contrast with what happens when the page on my site is validated by the https://validator.w3c.org site.

Start with your main site and work on the errors from the top down.  It can be brutal, frustrating work at first, but the end result is a cleaner page and a much greater understanding of scripting.  Remember, Google is your friend when it comes to understanding the errors' cause(s).

I would like to get this script working, but have had no luck and am looking for assistance. I have run the validator tool and looked at the errors. The errors appear not to be errors, as they are correct as far as I can tell. The drought script stops at this point -

<a class="hovertab" onmouseover="show_tab('Wyoming')">Wyoming</a><br/></td>
</tr>
</tbody>
</table>
<table width="662.09302325581" cellpadding="0" cellspacing="0">
<tbody><tr>
<td>
<div id="drought" class="frame_border center" style="width:662.09302325581px; height:496.56976744186px; position:relative">
<a href="http://droughtmonitor.unl.edu/data/png/current/current_total_trd.png" target="_blank" title="Larger Map"><img src="

I am not an expert in php, so am at a loss where to go from here and would add that all the other scripts that I have added to my site have worked just fine. I have checked other sites with this script and they all seem to work, so the issue must be with my site somewhere.

Any suggestions would be greatly appreciated.

Thanks, John
John
Westminster, MA USA

 

anything