Author Topic: Help with Red H Field Amplifier  (Read 327 times)

0 Members and 1 Guest are viewing this topic.

Offline Silversword

  • --Stan Y.
  • Forecaster
  • *****
  • Posts: 428
    • Up Country Maui Weather
Help with Red H Field Amplifier
« on: October 19, 2017, 02:31:35 AM »
Hi All,

It has been a long time since I have been here.  Hope all is well with all.

I have an issue with my Red H Field Amplifier. 

My controller was giving me a low voltage issue and was kinda cycling trying to re-boot.  Did some troubling shooting and came up that the H Field amplifier was the issue as I have an E Field system too. When I had a chance a couple of days later I went on the roof to see what the H Field box condition was. The container had sprung a leak.  I found over and inch of water in the box.  The amplifier board was soaked in that water for about a week or so.  Took the antenna system apart and took the ferrites out of the PVC and dried them out.  I think those are okay. 

The amplifier board was a mess.  I cleaned it up as much as possible and dried it up over my weather computer that has some heat and moving air to really dry it up.  Took a chance to see if it might be still functional and powered it up.  The red LED came on and the amber LED's blinked 4 times.  The green LED did not come on.  I pushed on the re-set button but nothing happened, so I just powered it down and powered it up again and the same result.  So I hope that the board might be okay but the re-set button might not be working.

I still need to put it all back together and see what happens.

Just in case that this amplifier board is bad, I am wondering if there are any of you might have one that is sitting in the closet that you might want to find a place to be used.

It may take more than a week for me to put it all back together for testing and reconstruction of the box to be more water resistant.

In the mean time I am using the E Field antenna system where I had the H Field connected on the controller system that would be the one closest to the GPS   When I tried to put the E Field system to the one next to it is not really stable for some reason but where I have it now seems to be working, at least I think so. Any suggestions or comments about this temporary setup would be appreciated.

I did write to Egan about getting a replacement kit for the Red H Field but he replied that they no longer have it in stock. So, if this board is gone I hope that there might be a replacement to be found somewhere out there.

Thanks again for any suggestions or comments on my issue on this subject.

Regards.

--Stan Y.
  Maui, Hawaii
 
Stan Y. - KH6HHG - Maui, Hawaii --- Blitzortung ID: 993 --- FlightRadar24 ID: F-PHOG1
Weather Display 10.37s Build 42
WDL 6.05
MS Windows 7 Pro
Dell Optiplex GX280-Intel Pentium 4 CPU 3.00GHz, 4 GB RAM
Davis Vantage Pro 2+ Wireless
1-Wire Lighting
Webcam: Axis 211

Offline miraculon

  • Sunrise Side Weather
  • Forecaster
  • *****
  • Posts: 2887
  • KE8DAF
    • Sunrise Side Weather in Rogers City MI USA
Re: Help with Red H Field Amplifier
« Reply #1 on: October 19, 2017, 08:49:04 AM »
Stan,

Sorry about your bad luck on this.

I looked and I do not have any spare RED amplifier parts.

I am not sure what you did to clean the board, but with the presence of moisture and voltage, there are probably dendrites shorting things out. If you haven't done so already, maybe some "Flux Off" with the brush and a thorough scrubbing of all possible PCB and connector areas might help. You also might need a slightly more aggressive "bake out", but not too hot.

I dunked my cell phone and got it working again with baking at 50C, but alas it failed again after a few days. This was in a controlled temperature chamber at work. I couldn't get at the boards to scrub as mentioned above.

Hopefully, someone will have an extra H-field board. Good luck.

Greg H.




Blitzortung Stations 668, 706 - CWOP CW4114 -  CoCoRaHS MI-PI-1

Offline Silversword

  • --Stan Y.
  • Forecaster
  • *****
  • Posts: 428
    • Up Country Maui Weather
Re: Help with Red H Field Amplifier
« Reply #2 on: October 19, 2017, 12:21:05 PM »
Hi Greg,

Thanks for the reply and suggestions.  I think I got the board pretty much cleaned up. So far the only thing on the board that is not working is the reset button.  I don't think that won't matter as I think it is there for testing only.

I have been keeping the board over my weather computer where it is warmer than room temps and it has been drying up pretty well for about a week now.

I hope that this board is still working when I can find the time to put it back together, if I cannot find a replacement, I will have to contend with the E Field system only.

Regards,

--Stan Y.
  Maui, Hawaii
Stan Y. - KH6HHG - Maui, Hawaii --- Blitzortung ID: 993 --- FlightRadar24 ID: F-PHOG1
Weather Display 10.37s Build 42
WDL 6.05
MS Windows 7 Pro
Dell Optiplex GX280-Intel Pentium 4 CPU 3.00GHz, 4 GB RAM
Davis Vantage Pro 2+ Wireless
1-Wire Lighting
Webcam: Axis 211

Offline Cutty Sark Sailor

  • WxElement panel
  • Forecaster
  • *****
  • Posts: 2806
    • Frankfort Weather - TwinHollies WeatherCenter
Re: Help with Red H Field Amplifier
« Reply #3 on: October 19, 2017, 12:46:09 PM »
Stan, I suspect that EGON has some reserve RED components for just such cases, should you actually need something...Especially since RED is NOT obsolete,...  .However, it might be an 'assemble it" kit... remember RED had to be constructed... unlike BLUE.  The 'reset' switch and 'gain' pot on the amplifier board aren't used unless you've selected 'enable potentiometer' on the main control settings or testing the board... they are pretty much 'standard' components, however. if I were concerned about possible contamination of them, I'd remove them and discard, and clean the board well...  I'd be more concerned about the ATmega8  IC socket developing contamination at one point... I'd probably either obtain a replacement locally, or remoe it and cleanup the ATmega8 and solder it directly, perhaps, if I developed issues later on. the RJ45 connector, cable and Jack and USB jack could also corrode, if they haven't already. Keep an eye on 'em and the E coax & connectors..
Cheer1
« Last Edit: October 19, 2017, 12:47:55 PM by Cutty Sark Sailor »

CoCoRaHS KY-FR-1  CWOP DW5536

       Blitzortung
       689
& 1439

sferics.us

 


Offline Silversword

  • --Stan Y.
  • Forecaster
  • *****
  • Posts: 428
    • Up Country Maui Weather
Re: Help with Red H Field Amplifier
« Reply #4 on: October 20, 2017, 01:12:59 AM »
Hi Cutty,

Thanks for your reply and suggestions.

I did write to Egon and he replied and mentioned that they don't have any Red H field amplifiers any more.

Okay on removing the reset button and potentiometer that might not be needed and might cause issues later.

The IC socket seems to be good as far that I can see with no corrosion in or around it.  I removed the IC and the pins looked clean.

The RJ45 socket and the cable connector looks clean as well.

I think that I have cleaned up the circuit board as much as I could without damaging other components.

Will see after I get it all back together one of these days when time permits.

Thanks again for your support with this project.

If it does not work, I hope that someone out there might have one that might be available.

Regards,

--Stan Y.
  Maui, Hawaii
 
Stan Y. - KH6HHG - Maui, Hawaii --- Blitzortung ID: 993 --- FlightRadar24 ID: F-PHOG1
Weather Display 10.37s Build 42
WDL 6.05
MS Windows 7 Pro
Dell Optiplex GX280-Intel Pentium 4 CPU 3.00GHz, 4 GB RAM
Davis Vantage Pro 2+ Wireless
1-Wire Lighting
Webcam: Axis 211

Offline Jumpin Joe

  • Forecaster
  • *****
  • Posts: 990
    • Joe's Live Weather
Re: Help with Red H Field Amplifier
« Reply #5 on: October 20, 2017, 10:26:03 AM »
Stan,

I sent you a PM.

Joe
Davis Pro 2 Plus Wireless D-FARS - Weather Link Serial 5.9.2
Weather Display Version10.37S Build 6
http://www.joesweather.info
Joe's Bloomsky 

CWOP: EW2334  Blitzortung ID: 791


Offline Silversword

  • --Stan Y.
  • Forecaster
  • *****
  • Posts: 428
    • Up Country Maui Weather
Re: Help with Red H Field Amplifier
« Reply #6 on: October 20, 2017, 12:17:44 PM »
Hi Joe,

I sent you an email to see what you have available.

Thank you for your reply and your support with this project.

I hope that all will work out.

Regards,

--Stan Y.
  Maui, Hawaii
Stan Y. - KH6HHG - Maui, Hawaii --- Blitzortung ID: 993 --- FlightRadar24 ID: F-PHOG1
Weather Display 10.37s Build 42
WDL 6.05
MS Windows 7 Pro
Dell Optiplex GX280-Intel Pentium 4 CPU 3.00GHz, 4 GB RAM
Davis Vantage Pro 2+ Wireless
1-Wire Lighting
Webcam: Axis 211

Offline Phil23

  • Contributor
  • ***
  • Posts: 124
    • Phil's Backyard
Re: Help with Red H Field Amplifier
« Reply #7 on: October 20, 2017, 07:10:11 PM »

The IC socket seems to be good as far that I can see with no corrosion in or around it.  I removed the IC and the pins looked clean.


I'd suspect one of the best places for corrosion shorts may actually be under the IC socket(s), where pins & tracks are close but not visible.
The ideal place for moisture to take a long time to dry out.

Next could be removing the sockets & cleaning under there before replacing them.

The sockets should be easy to remove if you first destroy the plastic with some small sharp side cutters.
Once the plastic's all gone, it's easy to remove the pins one by one without risk of damaging the board.

Cheers.

Offline Silversword

  • --Stan Y.
  • Forecaster
  • *****
  • Posts: 428
    • Up Country Maui Weather
Re: Help with Red H Field Amplifier
« Reply #8 on: October 21, 2017, 03:35:47 AM »
Hi Phil23,

Thanks for the suggestion.  I think that the IC socket might be good as I pulled the IC out and had it out and kept the board in a warm and ventilated spot over my weather computer for about a week.

When I have the time to put it all back together with the hope that the board will be working properly.  It might be a miracle if it does.

Regards,

--Stan Y.
   Maui, Hawaii
 
Stan Y. - KH6HHG - Maui, Hawaii --- Blitzortung ID: 993 --- FlightRadar24 ID: F-PHOG1
Weather Display 10.37s Build 42
WDL 6.05
MS Windows 7 Pro
Dell Optiplex GX280-Intel Pentium 4 CPU 3.00GHz, 4 GB RAM
Davis Vantage Pro 2+ Wireless
1-Wire Lighting
Webcam: Axis 211

 

anything