Author Topic: observerIP access extremely slow - is that normal?  (Read 400 times)

0 Members and 1 Guest are viewing this topic.

Offline timg11

  • Member
  • *
  • Posts: 1
observerIP access extremely slow - is that normal?
« on: January 27, 2018, 02:47:08 PM »
Hi. I'm have a new Ambient weather observerIP 4.1 (version 4.1.3) connected to Weather Station Model Number WS-1400-IP.

The observerIP is connected by Ethernet to my LAN.

I'm planning to set up local logging, but I want to be sure everything is working normally before making any changes.

The strange behavior I see is when connecting to observerIP at its local IP address on my LAN using a browser from another computer.
The page loading is almost comically slow. Loading the "live data" page takes about 5 minutes, with 15-20 second pauses for each row or item on a row.
Does this extreme slowness indicate a hardware problem with the ObserverIP or the WS-1400-IP?

It does seem to be sending valid data to weather underground.


Offline dupreezd

  • Forecaster
  • *****
  • Posts: 435
Re: observerIP access extremely slow - is that normal?
« Reply #1 on: January 27, 2018, 02:55:10 PM »
I notice that from time to time as well. A quick reboot and all is well again. When the slow down happens, I notice gaps in my data to WU.
Might be a memory leek.
WS-1200-IP | ObserverIP | Meteobridge 3.6
WU, PWSWeather - KTXCONRO61
CWOP - FW0717
Blitzortung 2100

Offline plb4333

  • Member
  • *
  • Posts: 1
Re: observerIP access extremely slow - is that normal?
« Reply #2 on: March 21, 2018, 05:00:37 PM »
Hi. I'm have a new Ambient weather observerIP 4.1 (version 4.1.3) connected to Weather Station Model Number WS-1400-IP.

The observerIP is connected by Ethernet to my LAN.

I'm planning to set up local logging, but I want to be sure everything is working normally before making any changes.

The strange behavior I see is when connecting to observerIP at its local IP address on my LAN using a browser from another computer.
The page loading is almost comically slow. Loading the "live data" page takes about 5 minutes, with 15-20 second pauses for each row or item on a row.
Does this extreme slowness indicate a hardware problem with the ObserverIP or the WS-1400-IP?

It does seem to be sending valid data to weather underground.

You might also want to upgrade to version 4.36 and then reboot. At last resort, there's a pin hole on the back for resetting the ObserverIP

Online quailvalleywx

  • Member
  • *
  • Posts: 12
Re: observerIP access extremely slow - is that normal?
« Reply #3 on: March 24, 2018, 06:02:40 PM »
I had seen the same slow down with version 3.1.2.  For now I send a software reboot command a couple nights a week and that seems to stay ahead of the memory leak and keep things fast.  I use this shell command from the Tasker app on an Android phone but it should work with a Linux machine, maybe even Windows powershell? if you can pipe the input:

(sleep 4;echo admin;sleep 4;echo admin;sleep 2;echo reboot;sleep 2)|telnet 192.168.1.175

Ambient Weather took telnet out of ObserverIP in later versions so you may have to flash an earlier version for telnet use.  Of course the real question is why haven't they fixed the slowness :(

Have you seen this page for potentially logging data?
https://obrienlabs.net/redirecting-weather-station-data-from-observerip/
Pat grabs the WU HTTP message locally and then forwards it to WU.

I save the data via a mysql database after implementing Pat's redirect via this php file: https://github.com/mrcodegh/SoilSensor_ESP12f/blob/master/updateweatherstation.php



Offline dupreezd

  • Forecaster
  • *****
  • Posts: 435
Re: observerIP access extremely slow - is that normal?
« Reply #4 on: March 24, 2018, 06:51:37 PM »
Quote
I had seen the same slow down with version 3.1.2.
After upgrading to 4.2.1, I might experience the slowdown every 3 to 4 months.

Quote
Ambient Weather took telnet out of ObserverIP in later versions so you may have to flash an earlier version for telnet use.  Of course the real question is why haven't they fixed the slowness
Ambient just released a new update to address this issue, BUT no telnet option anymore.

Quote
I save the data via a mysql database after implementing Pat's redirect via this php file:
I am doing the same thing via the re-direct, but just store the data in a flat file, not SQL.

Regards
WS-1200-IP | ObserverIP | Meteobridge 3.6
WU, PWSWeather - KTXCONRO61
CWOP - FW0717
Blitzortung 2100

 

anything