Author Topic: NaN and other issues - Saratoga Template and Meteobridge  (Read 523 times)

0 Members and 1 Guest are viewing this topic.

Offline chrisgrainger

  • Contributor
  • ***
  • Posts: 110
    • Top of The Rideau
NaN and other issues - Saratoga Template and Meteobridge
« on: November 20, 2017, 12:21:55 PM »
Hi Ken,

Going to post this at the Meteobridge support forum as well cause I think it may be a Meteobridge problem, but was wondering about your impression as well.

Got an email this morning from Wunderground saying that since 0430 this morning, I wasn't sending stuff to them.  I checked and sure enough, Meteobridge was showing no connections.  So, I rebooted the Bridge, reloaded all the templates, with no apparent change.  Also, the weather station website is showing calm winds, NAN for temperature, etc.  The bridge is showing no network traffic on the weather information sites I upload to.  Twitter is showing an error.  HTTP and FTP are showing checkmarks though.  If I try to load MBrealtime.txt, it shows a current file, but with tokens in it like this....

Code: [Select]

20/11/2017 12:04:08 [th0temp-act] [th0hum-act.0] [th0dew-act] [wind0avgwind-act] [wind0wind-act] [wind0dir-act] [rain0rate-act] 0.0 [thb0seapress-act] [wind0dir-act] [wind0wind-act=bft.0] m/s C hPa mm -- -- 61.8 1056.0 4.0 [thb0temp-act] [thb0hum-act] [wind0chill-act] -- -2.2 00:00 -7.2 04:20 6.3 02:28 10.7 02:23 1013.7 04:27 1009.2 00:00 3.4 11632 [wind0wind-max10] 0 0 -- -- -- -- [rain0total-sum60] -- 1 -- -- -- m -- 09:24 -- -- --


As I said, this happened sometime last night.  I rebooted the Meteobridge, the router, the ISP modem....

Have you or anyone else seen this before?

Cheers!

Chris

Offline chrisgrainger

  • Contributor
  • ***
  • Posts: 110
    • Top of The Rideau
Re: NaN and other issues - Saratoga Template and Meteobridge
« Reply #1 on: November 20, 2017, 12:47:14 PM »
Doh!


I really need to check everything before posting a question......


Looks as if I have a connection problem between Meteobridge and the Vue....  Battery maybe?


Chris

Offline saratogaWX

  • Administrator
  • Forecaster
  • *****
  • Posts: 6766
  • Saratoga, CA, USA Weather - free PHP scripts
    • Saratoga-Weather.org
Re: NaN and other issues - Saratoga Template and Meteobridge
« Reply #2 on: November 20, 2017, 02:42:12 PM »
Yep, that will do it.  When Meteobridge doesn't have current data from the station, the tags are not converted (as shown in your MB_realtime.txt and MBtags.php. Once Meteobridge starts getting data from your station, the problem should be resolved.
Ken True/Saratoga, CA, USA main site: saratoga-weather.org
Davis VP1+ FARS, Boltek-PCI/NexStorm, microSferics ToA, Blitzortung RED, GRLevel3, WD, WL, VWS, Cumulus, Meteobridge/hub
Free weather PHP scripts/website templates - update notifications on Twitter saratogaWXPHP

 

anything