Author Topic: RPi Zero power consumption running weewx  (Read 1422 times)

0 Members and 1 Guest are viewing this topic.

Offline Mitch W4OA

  • Member
  • *
  • Posts: 41
RPi Zero power consumption running weewx
« on: January 06, 2016, 06:10:32 PM »
I am working on a system for installation in a remote location. I want to use a Raspberry Pi and weenwx to report to multiple sites.


I have been working with RPi models B, B+ and the Pi 2. I recently acquired the new $5 Pi Zero. I literally took the SD card with Raspian Jessie and weewx out of a Model B and put it into it the Zero. It seems to run just fine, although I am having problems with weewx starting regardless of which RPi board I am using. (See my post in the weewx forum for a description of the problem.)


[Update - I was directed to the Google weewx group, found the solution to the RPi weewx startup problem - put a 30 second delay at the beginning of the /etc/init.d/weewx script. I tested the solution on the RPi Zero and the RPi 2, worked on both.]


The remarkable thing about the RPi Zero installation is that it uses less than one watt of power! See the attached pictures.


Mitch, W4OA
Opelika, AL
KALOPELI3

« Last Edit: January 07, 2016, 11:26:26 AM by Mitch W4OA »

Offline vreihen

  • El Niņo chaser
  • Forecaster
  • *****
  • Posts: 708
  • K2BIG
Re: RPi Zero power consumption running weewx
« Reply #1 on: January 06, 2016, 07:09:58 PM »
Why are you surprised?  The CPU chip was intended for use in cell phones, where battery life is critical.....
WU Gold Stars for everyone! :lol:

 

anything